Negative Ion Beam (negativeIonBeamT.pre)

Keywords:

negativeIonBeamT, beam transport, monte carlo, electrostatic

Problem description

VSim may be used to model ion beam transport and particle dynamics where the beam is represented by kinetic simulation particles. Low density background gasses can cause instabilities in the beams due to collisions between the beam particles and the background gas.

In this simulation, a beam of H- ions propagates through a background H2 gas. Collisions between the beam ions and the background gas produce electrons, H2+, and neutral H through the following reactions:

\(H^- + H_{2} \rightarrow H_{-} + H_{2} ^+ + e^-\) (ion impact ionization)

\(e^- + H_{2} \rightarrow H_{2} ^+ + 2e^-\) (electron impact ionization)

\(H^- + H_{2} \rightarrow H + H_{2} + e^-\) (detachment)

\(H^- + e^- \rightarrow H + 2e^-\) (stripping)

There are other reactions that are not included in this tutorial simulation. Typically these reactions have low cross sections. Fig. 517 shows the cross sections for the above reactions as a function of incident energy.

image 1

Fig. 517 Cross sections for the four collision reactions included in this example.

This simulation can be performed with a VSimPD license.

Opening the Simulation

The Kinetic Collisions example is accessed from within VSimComposer by the following actions:

  • Select the NewFrom Example… menu item in the File menu.
  • In the resulting Examples window expand the VSim for Plasma Discharges option.
  • Expand the Processes (text-based setup) option.
  • Select “Negative Ion Beam” and press the Choose button.
  • In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as shown in Fig. 518.

image 1

Fig. 518 Setup Window for the Kinetic Collisions example.

Input File Features

This input file contains a number of different kinetic species as well as a background fluid description of a gas. Ionization collisions between kinetic particles and the background gas are described by Monte Carlo interaction blocks of kind impactIonization, and detachment of electrons due to a collision with the background gas are of kind negativeIonDetachment. Collisions between kinetic particles and other kinetic particles are described in the input file by an interaction of kind binaryIonization.

The fields are electrostatically solved for at each time step, including the fields due to all charged particles, subject to the boundary conditions specified in the input file. There are a number of histories that record the number of particles for different species, their energies, as well as currents absorbed at the boundaries.

Running the Simulation

After performing the above actions, continue as follows:

  • Proceed to the Run Window by pressing the Run button in the left column of buttons.
  • To run the file, click on the Run button in the upper left corner of the window. You will see the output of the run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is shown in the window below.
image 1

Fig. 519 The Run Window at the end of execution.

Analyzing the Results

If it is desired to calculate the density of the electrons the analysis script computePtclNumDensity.py must be used. First click on the Analyze Tab. Then select computePtclNumDensity.py From the drop down menu in the Control Pane. This script accepts the simulationName of the simulation (Name of the input file) and speciesName to be calculated (species of particles). In this case the simulationName is negativeIonBeamT and the speciesName is electrons. Then click on the Run button. The resulting data will be visualizable as “electronsDensity” under the Scalar Data menu in the Visualize Tab. The density of H2plus, Hminus or Hneutral can also be calculated if those species names are used in place of electrons.

Visualizing the Results

After performing the above actions, continue as follows:

  • Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

Under Particle Data select H2plus and electrons to view the beam traversing the simulation space.

You can also add electric potential contours by expanding Scalar Data and selecting phi, and clicking Display Contours in the bottom half of the Visualization Controls pane. The visualization of the particles and contours is shown in Fig. 520.

image 1

Fig. 520 Visualization of particles and potential field.

Further Experiments

The background gas pressure is higher than one would typically see in an accelerator in this example so that the example will produce results quickly. Decreasing the pressure will give the same results, but over longer time scales.

Since this beam is negatively charged, it repulses electrons from the region near the beam. Decreasing the beam current will produce more neutralizing H2+ near the beam as the electrons can more effectively ionize the background H2 gas in that area.